'버전'에 해당되는 글 1건

  1. 2009.11.19 Rails 2.3.4 (2.0 이상)에서의 scaffold와 paginate
Leopard 10.5.7에 설치된 Rails는 2.3.4.
2.0이상의 버전에서는 scaffold가 삭제되어서, scaffold를 사용하는 예제 코드가 작동하지 않음.

책에 나온대로 간단한 웹 어플을 테스트 하니, scaffold 관련 오류
undefined method scaffold

1) scaffold 플러그 인을 설치 한다
>> script/plugin install scaffolding
>>script/plugin install svn://errtheblog.com/svn/plugins/classic_pagination
scaffold 플러그 인은 설치완료,
paginate 플러그인은 errtheblog.com에 연결하지 못하다면서 설치 실패,
웹 어플을 실행해보니 

2) paginate 플러그인 설치
undefined method `paginate' 
errtheblog.com에 접근하지 못해 paginate 플러그인이 설치 되지 않음.

pagingate 플러그인 설치가 용이 하지 않아 다른 방법 사용 (http://sokum.tistory.com/49)
rails 로 어플리케이션을 생서하면서 버전을 지정할수 있다.
>>rails _1.8.4_ phonebook

이후 예제 코드는 정상적으로 동작.



저작자 표시
신고
Posted by 영겁회귀

티스토리 툴바